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Terminology
 / = Regular Slash (less slanted) 

 ⁄ =  Fraction Slash (more slanted). This is sometimes called a virgule.

Proper Fraction Pro Overview
Format Selected Fraction: This formats a selection of unformatted text that 

constitutes a fraction (character, slash, character). It verifies that the selection 

contains a slash with a character before and after, and then formats the selection 

according to the defined preferences. 

Format Multiple Fractions: This searches the Selection, Story, Document, 

or Selected Frame(s) for fractions. It assumes they are numerical fractions, yet 

intelligently skips dates such as 8/30/16. It offers flexibility by allowing you to define 

custom kerning for specific numbers before and after the fraction slash. Beyond 

that, you can apply those settings to fractions found in a specific font.

Both techniques can format fractions using OpenType formatting or by 

horizontally/vertically scaling the numerator and denominator for fonts that don’t 

have OpenType fractions. Thin strokes can optionally be applied so the fractions 

match the weight of full size characters. 

Choose Where to Search for Fractions

Requires Adobe InDesign or InCopy for Mac or PC
Proper Fraction Pro works inside of InDesign or InCopy CS3 or later  

(tested through CS6 and Creative Cloud CC 2015).

Preferences

OVERVIEW, SYSTEM REQUIREMENTS & SCREENSHOTS
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HOW TO INSTALL

1. Open the Scripts panel as follows: 

In CS5 or Later: Go into the Window > Utilities > Scripts. 

In CS4 or CS3: Go into the Window > Automation > Scripts.

2. In the Scripts panel you’ll see Application and User folders. Scripts can be 

installed into either, but only admins can install into the Application folder. 

If you’re not an admin (or aren’t sure), choose the User folder. With one of the 

folders selected, at the top right of the panel go into the menu and choose 

Reveal in Finder (Mac) or Reveal in Explorer (PC).

3. You should now see a Scripts Panel folder. Drag the script files/folder into the 

Scripts Panel folder and it’s installed! 

4. Switch back to InDesign and the script will be listed under the folder you put it 

in. To start the script just double-click it and enjoy!

Scripts Panel Folder Location
Curious where the Scripts Panel folders are located? 

InCopy installations are identical, except the folder is InCopy instead of InDesign.

Mac
• Application Folder: Hard Drive > Applications > Adobe InDesign 

[version number] > Scripts > Scripts Panel

• User Folder: Hard Drive > Users > [username] > Library > Preferences > 

Adobe InDesign > Version X.X > Scripts > Scripts Panel

Windows 7 & Later
• Application Folder: C:Drive > Program Files > Adobe > Adobe InDesign 

[version number] > Scripts > Scripts Panel

• User Folder: C:Drive > Users > [username] > AppData > Roaming > Adobe > 

InDesign > Version X.X > [en_US or other language] > Scripts > Scripts Panel

Windows XP
• Application Folder: C:Drive > Program Files > Adobe > Adobe InDesign 

[version number] > Scripts > Scripts Panel

• User Folder: C:Drive > Documents and Settings > [username] > Application Data > 

Adobe > InDesign > Version X.X > [en_US or other language] > Scripts > 

Scripts Panel

http://www.danrodney.com
http://www.danrodney.com
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USING PROPER FRACTION PRO

Step 2

Open the Scripts panel

In CS5 or later choose Window > Utilities > Scripts. 

In CS4–CS3 choose Window > Automation > Scripts.

Step 1

Make a Selection

To format one fraction: 

Select the fraction (numerator/denominator).

To format multiple fractions: 

 No selection is required to  

format all fractions in the document.  

If you want to convert only certain fractions,  

select some text or text frame(s).

Step 3

Double-click the Desired Script

Step 4

Choose What to Search

Format Selected Fraction will turn the selected  

text into a formatted fraction and you are done!

Format Multiple Fractions has one more step. 

Format Multiple Fractions will confirm  

what content will be searched. 

Click OK when done.

http://www.danrodney.com
http://www.danrodney.com
mailto:dan@danrodney.com


empowering people through technology

Proper Fraction Pro 2.1 for Adobe InDesign & InCopy COPYRIGHT © 2004–2015 DANRODNEY.COM dan@danrodney.com  PAGE 5

DESCRIPTION OF FEATURES

Sizing (Horizontal & Vertical Scale)
To scale down the numerator or denominator, horizontal and vertical scale is 

applied as specified in the preferences. One of the nice things about applying 

scaling instead of changing the type size is that you can see the percentage of scale 

in case you want to experiment with other type sizes. It  allows the type size to be 

changed and the numbers remain scaled down. If only the baseline shift could be 

a percentage then the fractions could scale completely! Of course with Format 

Multiple Fractions you can just run it again to fix them if you change the font size.

Fraction Slash
Sometimes called a Virgule, the Fraction Slash is a less vertical slash and is the proper 

slash to use in a fraction.

Custom Kerning
When Custom Kerning is checked on, the Numerator and Denominator Kern 

amounts towards the top of the window will be ignored. Instead the kerning will 

be specific to a number when it is before or after a fraction slash. This allows a very 

exact method for dealing with kerning. It may take a little while for you to figure out 

the desired settings for a font (and each font may be different) but once you have it 

set, you’ll get perfectly kerned fractions every time!

Font Search
Every font requires different kerning. Proper Fraction Pro has the powerful ability 

to define custom kerning it made sense to be able to target those preferences to a 

specific font. To choose a font check on Change Font and select the font from the 

menu. Be sure to uncheck Search All Fonts. For more information on setting this 

up for multiple fonts, please refer to the Tips on page 7.

Stroke Numerator & Denominator
When using non-OpenType fonts the numerator and denominator are scaled down. 

This makes them appear thinner than full size characters such as the fraction slash. 

To compensate, Proper Fraction Pro looks at the current character color and adds a 

thin stroke with that same color, thickening up the character. The results are excellent.

OpenType Formatting
Some OpenType fonts have numerator and denominator characters specially 

designed to the proper size, weight and position. These typically look better than 

scaled down characters. To use them we apply OpenType’s Fractions option. But not 

all fonts properly format all three type of fractions: basic (ie: 1⁄2 or 1⁄4), extended 

(ie: 1⁄8 or 2 ⁄3), or arbitrary (ie: 11⁄16 or 99 ⁄100). In such cases, we can apply OpenType’s 

Numerator & Denominator options. Proper Fraction Pro can apply either.

Date Detection
This is the invisible feature you didn’t know you needed. A fraction is a slash with 

numbers around it. Dates such as 8/30/16 could be wrongly identified as a fraction. 

Proper Fraction Pro detects dates and does not format them.

http://www.danrodney.com
http://www.danrodney.com
mailto:dan@danrodney.com
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Q. How do I remove the stroke from my fractions?

A. Check on Stroke Numerator & Denominator and set the weight to 0%. 

Run Proper Fraction Pro again to format the fractions with no stroke. You can 

then uncheck Stroke Numerator & Denominator if you wish. NOTE: By design, 

unchecking the Stroke Numerator & Denominator option does not alter the 

stroke. This allows existing strokes on the text to remain unaltered.

Q. How do I use the OpenType formatting and what’s the difference between 

the two options?

A. Some OpenType fonts convert only certain fractions when using the Fractions 

attribute. If a fraction isn’t formatted, we can apply the Numerator and 

Denominator attributes to these non-standard fractions. Typically the 

Fractions option is best for fonts that support it (often yields better kerning, 

etc.) but Numerator & Denominator is there for fonts that don’t. If one option 

doesn’t work try experimenting with the other.

Q. When I turn on the OpenType formatting, my numerator & denominator 

get very small and the numerator is shifted too high. What is going on?

A. OpenType fraction characters are already sized and positioned according to 

the artistic vision of the font designer. They typically do not need additional 

resizing or baseline shift. When using OpenType formatting you should set the 

Numerator and Denominator Baseline Shift to 0% and Horizontal Scale/

Vertical Scale to 100%.

Q. Must I use the OpenType formatting when using OpenType fonts?

A. No, some OpenType fonts don’t support OpenType fraction formatting or don’t 

support it fully. If you turn off the OpenType option, Proper Fraction Pro will 

apply preference settings like it would for any font. Adding the stroke option can 

even out the weight to better match full size characters. The results can look 

quite comparable to an OpenType fraction.

Q. Why do you use percentages instead of normal kerning amounts?

A. By using percentages instead of specific amounts for any formatting option, 

Proper Fraction Pro creates excellent fractions independent of the font size. 

This is a much more flexible approach.

Q. The progress bar (CS3 & later) sometimes ends early. Is it missing fractions?

A. No need for worry here. All fractions are being properly formatted. The 

progress bar’s initial length (and count) is based on the number of “possible” 

fractions—which is the number of slashes found. Things like dates are not 

fractions and will be skipped. They were included in the initial count—twice 

actually as they contain two slashes! This means the progress bar may appear 

to end before finishing, but all “real” fractions have been formatted.

Q. What’s the “Limit to 1 Numerator” option for?

A. Some users rarely have more than a one digit numerator. To make it easier to 

deal with mixed fractions (a whole number in front of a fraction) this option will 

only format one numerator, assuming that if there were any numbers in front 

that they are supposed to be whole numbers. That means you can type 11/2 

(with no spaces) and Format Multiple Fractions will turn it into 11⁄2. 

Q. I’ve chosen a font in Preferences. Why does “Format Selected Fraction” 

still format fractions when they’re in a different font?

A. By design Format Selected Fraction only identifies that the selection contains 

a slash with characters before and after it. Format Multiple Fractions allows 

for formatting of fractions that are font dependant.

Q. Can I undo the fraction formatting done by Proper Fraction Pro?

A. Technically yes, but it would be time consuming if a lot of fractions 

were formatted. There are many things that get changed: size, baseline shift, 

stroke, etc. Therefore it would require numerous undos per fraction. 

I recommend saving your file before running Proper Fraction Pro.

Q. Can I format a non-numerical fraction such as “a/b”?

A. Yes, select the fraction and double–click Format Selected Fraction. Please 

note that Format Multiple Fractions only formats numerical fractions and will 

not format this type of fraction.

Q. In Adobe InCopy, Proper Fraction Pro seems to run slowly.

A. For an unknown reason it runs slower in Galley and Story views.  

Switching to Layout view should improve performance. 

FAQS & TROUBLESHOOTING

http://www.danrodney.com
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Different Settings for Multiple Fonts:
When you edit the Preferences and set a font, this setting is saved in the preference 

file in the Proper Fraction Pro folder. This allows you to have multiple copies, each 

for use with a different font. Duplicate the entire Proper Fraction Pro folder for 

each desired font. I recommend naming the folders according to the font. When 

you’re done the Scripts panel will look something like this:

NOTE: Format Selected Fraction will format any selected fraction regardless of the 

font set in preferences. You must be careful to use the copy that matches the font 

of the currently selected fraction. It will not double check for you. 

Speed It Up with a Keystroke:
You can assign a keyboard shortcut to Proper Fraction Pro. This enables you to 

press a keystroke to launch it instead of using the Scripts panel. 

    - Go into the Edit menu and choose Keyboard Shortcuts. 

- From the Product Area menu choose Scripts. 

-  From the list choose one of the actions, such as  

Proper Fraction Pro 2.1: Format Multiple Fractions

    - Towards the bottom click in the empty field under New Shortcut. 

- Press the desired keys on the keyboard 

  For example Option–F (Mac) or Alt–F (Pc). 

- Click Assign. 

- Click OK.

Restoring the Default Preferences:
In the Proper Fraction Pro folder is a file called “z Proper Fraction Preference File.

txt” After you trash this file, the default preferences will be restored the next time 

you run Proper Fraction Pro. Here’s an easy way to delete this file:

• Select the “z Proper Fraction Preference File.txt” 

• From the Scripts panel menu  choose Delete Script File.

• When asked to confirm click Yes.

TIPS

http://www.danrodney.com
http://www.danrodney.com
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VERSION RELEASE NOTES

Version 2.1 released 8/21/2015

• Updated Preferences dialog to be clearer by spelling out abbreviated 

words: BShift is now Baseline Shift, VScale is now Vertical Scale, 

HScale is now Horizontal Scale

• Fixed a bug that sometimes prevented the interface from appearing.

Version 2.02 released 3/11/2008

• A bug has been fixed that affected the Format Multiple Fractions feature. 

The problem prevented fractions from being properly formatted when a non-

standard space character (hair space, thin space, etc.) was before the fraction. 

Fractions should now get proper formatting even with these special characters.

• Preferences Version 1.0: No change was made to prefs file. You can reuse 

previous pref files (z Proper Fraction Preference File.txt) with this version.

Version 2.01 released 2/04/2008

• The kerning pairs preferences now allow larger negative amounts. The previous 

limit of –1000 has been increased to –8000. This allows for more space to 

be removed.

• Preferences Version 1.0: No change was made to prefs file. You can reuse 

previous pref files (z Proper Fraction Preference File.txt) with this version.

Version 2.0 released 9/17/2007

• Initial release of “Pro” Version with many new features such as a Preferences 

window, fraction search, search by font, stroke, OpenType support, date 

detection, and more.

• Proper Fraction Lite (Free) continues to work in InDesign CS, but Pro version 

requires CS2 or later.

• Pro version adds a progress bar. (Only works in CS3 and later.)

• Preferences Version 1.0: In the future, if the preference version changes, you 

may not be able to reuse your previous preference file. If the preference version 

remains the same, you can reuse your existing preferences by moving the 

preference file into the new script folder.)

Version 1.1 released 06/21/2006

• Minor update to Proper Fraction Lite (Free).

• Added instructions for CS2 installation.

Version 1.0 released 12/07/2005

• Initially release (of free Lite version). Was designed to add Quark’s Make Fraction 

command which wasn’t available in InDesign.

http://www.danrodney.com
http://www.danrodney.com
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LICENSING & LEGAL

Purchasing
Visit http://www.danrodney.com or email dan@danrodney.com

Single-User License
Allows an individual to install and use Proper Fraction Pro on as many machines 

as he/she works on. It is not to be used by multiple persons. Only the person who 

purchased the license has the right to use it. Multiple installed copies cannot be 

used concurrently. Since there is only one licensee, he/she can only be using one 

copy at a time. This license is nontransferable. 

Multi-User License
Allows a company, organization, household, etc. to install and use Proper Fraction 

Pro on multiple machines. The number of copies that can be installed and 

used concurrently depends on the number of licenses purchased. This license 

is nontransferable.

Terms of Use (Boring Legal Stuff)
Use of Proper Fraction Pro is subject to the following terms: 

Proper Fraction Pro is the sole property of Dan Rodney (Copyright © 2004–2015). 

Proper Fraction Pro is NOT to be distributed freely. 

No part of the script files can be used and/or redistributed as your own.  

In other words: “Please don’t steal my hard work!” 

While I have tested it to the best of my ability and know it to work as I intended, like 

any software there may be bugs that I have yet to find. It is provided “as is” with no 

guarantee of specific functionality. I recommend that you save frequently and keep 

backups of your documents. I am not responsible for any damages or liabilities 

incurred by the use of this product. 

In other words: I’ve worked hard to make sure things should work fine, but in case I 

made a boo-boo please don’t sue me.
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